# CVE-2021-27378: Incorrect check on buffer length in rand_core

> Insufficient buffer checks in rand_core allow seeding with too little data, weakening random number generation security.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-41851, GHSA-w7j2-35mf-95p7, RUSTSEC-2021-0023, UBUNTU-CVE-2021-27378

## What is CVE-2021-27378?

CVE-2021-27378 is a critical vulnerability in n/a, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the rand_core crate before 0.6.2 for Rust. Because read_u32_into and read_u64_into mishandle certain buffer-length checks, a random number generator may be seeded with too little data.

Weakness: CWE-131 (Incorrect Calculation of Buffer Size)

## Which versions are affected by CVE-2021-27378?

3 open source packages ship an affected version, including rand_core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rand_core` | crates.io | From 0.6.0 | 0.6.2 |
| `rand_core` | crates.io | From 0.6.0 | 0.6.2 |
| `rand_core` | crates.io | From 0.6.0 | 0.6.2 |

Products: Rand Core Project Rand Core.

## How do I fix CVE-2021-27378?

Upgrade rand_core to 0.6.2 or later.

## Is CVE-2021-27378 being exploited?

There is no known exploitation of CVE-2021-27378 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27378 and fix it if it is affected.

What it is: CVE-2021-27378 is a critical vulnerability in n/a, published on 18 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27378 in the wild and no public exploit code.

Affected packages and fixed versions:
- rand_core (crates.io): affected from 0.6.0; fixed in 0.6.2
- rand_core (crates.io): affected from 0.6.0; fixed in 0.6.2
- rand_core (crates.io): affected from 0.6.0; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27378/ (Markdown: https://insights.sbomify.com/CVE-2021-27378/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27378
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27378
- OSV: https://osv.dev/vulnerability/CVE-2021-27378

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27378/
Summaries are generated and may contain mistakes; the official description above is the record.
