# CVE-2021-27516: URIjs Hostname spoofing via backslashes in URL

> URI.js mishandles backslashes in URIs, causing them to be interpreted as relative paths, potentially bypassing security checks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p6j9-7xhc-rhwp

## What is CVE-2021-27516?

CVE-2021-27516 is a high-severity vulnerability in n/a, published on 21 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

URI.js (aka urijs) before 1.19.6 mishandles certain uses of backslash such as http:\/ and interprets the URI as a relative path.

## Which versions are affected by CVE-2021-27516?

2 open source packages ship an affected version, including urijs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urijs` | npm | All versions | 1.19.6 |
| `urijs` | npm | All versions | 1.19.6 |

Products: Uri.js Project Uri.js.

## How do I fix CVE-2021-27516?

Upgrade urijs to 1.19.6 or later.

## Is CVE-2021-27516 being exploited?

There is no known exploitation of CVE-2021-27516 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-0868](https://insights.sbomify.com/CVE-2022-0868/): Open Redirect in medialize/uri.js (high 8.0)
- [CVE-2022-1243](https://insights.sbomify.com/CVE-2022-1243/): CRHTLF can lead to invalid protocol extraction potentially leading to XSS in medialize/uri.js (high 7.2)
- [CVE-2022-1233](https://insights.sbomify.com/CVE-2022-1233/): URL Confusion When Scheme Not Supplied in medialize/uri.js (medium 6.5)
- [CVE-2020-26291](https://insights.sbomify.com/CVE-2020-26291/): Hostname spoofing in URI.js (medium 6.5)
- [CVE-2022-24723](https://insights.sbomify.com/CVE-2022-24723/): Improper Input Validation in URI.js (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27516 and fix it if it is affected.

What it is: CVE-2021-27516 is a high-severity vulnerability in n/a, published on 21 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27516 in the wild and no public exploit code.

Affected packages and fixed versions:
- urijs (npm): affected all versions; fixed in 1.19.6
- urijs (npm): affected all versions; fixed in 1.19.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27516/ (Markdown: https://insights.sbomify.com/CVE-2021-27516/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27516
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27516
- OSV: https://osv.dev/vulnerability/CVE-2021-27516

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27516/
Summaries are generated and may contain mistakes; the official description above is the record.
