CVE-2021-27568 Improper Check for Unusual or Exceptional Conditions in json-smart
An uncaught exception in the json-smart library can cause application crashes or leak sensitive information, requiring developers to upgrade the dependency.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-27568?
CVE-2021-27568 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 23 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in netplex json-smart-v1 through 2015-10-23 and json-smart-v2 through 2.4. An exception is thrown from a function, but it is not caught, as demonstrated by NumberFormatException. When it is not caught, it may cause programs using the library to crash or expose sensitive information.
Weakness: CWE-754
Which versions are affected by CVE-2021-27568?
8 open source packages ship an affected version, including net.minidev:json-smart and net.minidev:json-smart-mini. It affects 7 products.
| Package | Affected | Fixed in |
|---|---|---|
net.minidev:json-smart Maven | All versions | 1.3.2 |
net.minidev:json-smart Maven | All versions | 1.3.2 |
net.minidev:json-smart Maven | From 2.0.0 | 2.3.1 |
net.minidev:json-smart Maven | From 2.0.0 | 2.3.1 |
net.minidev:json-smart Maven | From 2.4.0 | 2.4.1 |
net.minidev:json-smart Maven | From 2.4.0 | 2.4.1 |
2 more packages
net.minidev:json-smart-mini Maven | All versions | 1.3.2 |
net.minidev:json-smart-mini Maven | All versions | 1.3.2 |
Products include Json-Smart Project Json-Smart-V1, Json-Smart Project Json-Smart-V2, Oracle Communications Cloud Native Core Policy, Oracle Oss Support Tools, Oracle Peoplesoft Enterprise Peopletools, Oracle Utilities Framework and 1 more.
How do I fix CVE-2021-27568?
Upgrade net.minidev:json-smart to a fixed version for your release line: 1.3.2, 2.3.1 or 2.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-27568 being exploited?
There is no known exploitation of CVE-2021-27568 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Oracle Communications Cloud Native Core Policy
All Oracle Communications Cloud Native Core Policy vulnerabilities
Sources
Also known as GHSA-v528-7hrm-frqp.