# CVE-2021-27568: Improper Check for Unusual or Exceptional Conditions in json-smart

> An uncaught exception in the json-smart library can cause application crashes or leak sensitive information, requiring developers to upgrade the dependency.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Feb 2021
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-v528-7hrm-frqp

## What is CVE-2021-27568?

CVE-2021-27568 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 23 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in netplex json-smart-v1 through 2015-10-23 and json-smart-v2 through 2.4. An exception is thrown from a function, but it is not caught, as demonstrated by NumberFormatException. When it is not caught, it may cause programs using the library to crash or expose sensitive information.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2021-27568?

8 open source packages ship an affected version, including net.minidev:json-smart and net.minidev:json-smart-mini. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.minidev:json-smart` | Maven | All versions | 1.3.2 |
| `net.minidev:json-smart` | Maven | All versions | 1.3.2 |
| `net.minidev:json-smart` | Maven | From 2.0.0 | 2.3.1 |
| `net.minidev:json-smart` | Maven | From 2.0.0 | 2.3.1 |
| `net.minidev:json-smart` | Maven | From 2.4.0 | 2.4.1 |
| `net.minidev:json-smart` | Maven | From 2.4.0 | 2.4.1 |
| `net.minidev:json-smart-mini` | Maven | All versions | 1.3.2 |
| `net.minidev:json-smart-mini` | Maven | All versions | 1.3.2 |

Products: Json-Smart Project Json-Smart-V1, Json-Smart Project Json-Smart-V2, Oracle Communications Cloud Native Core Policy, Oracle Oss Support Tools, Oracle Peoplesoft Enterprise Peopletools, Oracle Utilities Framework, Oracle Weblogic Server.

## How do I fix CVE-2021-27568?

Upgrade net.minidev:json-smart to a fixed version for your release line: 1.3.2, 2.3.1 or 2.4.1.

## Is CVE-2021-27568 being exploited?

There is no known exploitation of CVE-2021-27568 in the wild and no public exploit code.

Public exploit code:

- Demo of CVE-2021-27568: Insecure randomness in token generation (github_poc): https://github.com/arsalanraja987/java-insecure-random-cve-2021-27568

## Other vulnerabilities in Oracle Communications Cloud Native Core Policy

- [CVE-2021-31684](https://insights.sbomify.com/CVE-2021-31684/): Out of bounds read in json-smart (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27568 and fix it if it is affected.

What it is: CVE-2021-27568 is a medium-severity denial of service vulnerability in Oracle Communications Cloud Native Core Policy, published on 23 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27568 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.minidev:json-smart (Maven): affected all versions; fixed in 1.3.2
- net.minidev:json-smart (Maven): affected all versions; fixed in 1.3.2
- net.minidev:json-smart (Maven): affected from 2.0.0; fixed in 2.3.1
- net.minidev:json-smart (Maven): affected from 2.0.0; fixed in 2.3.1
- net.minidev:json-smart (Maven): affected from 2.4.0; fixed in 2.4.1
- net.minidev:json-smart (Maven): affected from 2.4.0; fixed in 2.4.1
- net.minidev:json-smart-mini (Maven): affected all versions; fixed in 1.3.2
- net.minidev:json-smart-mini (Maven): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27568/ (Markdown: https://insights.sbomify.com/CVE-2021-27568/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27568
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27568
- OSV: https://osv.dev/vulnerability/CVE-2021-27568

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27568/
Summaries are generated and may contain mistakes; the official description above is the record.
