{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-27578 in the wild and no public exploit code.","fix":"Upgrade org.apache.zeppelin:zeppelin to 0.9.0 or later.","what":"CVE-2021-27578 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-27578 and fix it if it is affected.\n\nWhat it is: CVE-2021-27578 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-27578 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zeppelin:zeppelin (Maven): affected all versions; fixed in 0.9.0\n- org.apache.zeppelin:zeppelin (Maven): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-27578/ (Markdown: https://insights.sbomify.com/CVE-2021-27578/index.md)","id":"CVE-2021-27578","markdown":"https://insights.sbomify.com/CVE-2021-27578/index.md","name":"CVE-2021-27578","record":{"aliases":["GHSA-mf7q-gw5f-q8jj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Zeppelin","requires_auth":"none","summary":"An attacker can inject malicious scripts via the markdown interpreter in Apache Zeppelin, potentially executing code in the victim's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zeppelin","vendor":"apache"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross Site Scripting vulnerability in markdown interpreter of Apache Zeppelin allows an attacker to inject malicious scripts. This issue affects Apache Zeppelin Apache Zeppelin versions prior to 0.9.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross Site Scripting in markdown interpreter","id":"CVE-2021-27578","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":6,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2021-27579"},"packages":[{"ecosystem":"Maven","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin","purl":null,"source":"GHSA-mf7q-gw5f-q8jj"},{"ecosystem":"Maven","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.zeppelin:zeppelin","purl":"pkg:maven/org.apache.zeppelin/zeppelin","source":"GHSA-mf7q-gw5f-q8jj"}],"prev":{"headline":"Incorrect handling of url fragment leads to cache poisoning","id":"CVE-2021-27577"},"products":["Apache Zeppelin"],"published":"2021-09-02","related":[{"cvss_score":9.8,"headline":"Apache Zeppelin: Remote code execution by adding malicious JDBC connection string","id":"CVE-2024-31864","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"Apache Zeppelin: Interpreter download command does not escape malicious code injection","id":"CVE-2024-31866","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"bash command injection in spark interpreter","id":"CVE-2019-10095","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":8.8,"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.1,"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775","kev_date_added":null,"published":"2025-08-03"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string","id":"CVE-2024-52279","kev_date_added":null,"published":"2025-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"An attacker can inject malicious scripts via the markdown interpreter in Apache Zeppelin, potentially executing code in the victim's browser.","url":"https://insights.sbomify.com/CVE-2021-27578/"}