# CVE-2021-27578: Cross Site Scripting in markdown interpreter

> An attacker can inject malicious scripts via the markdown interpreter in Apache Zeppelin, potentially executing code in the victim's browser.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Sep 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-mf7q-gw5f-q8jj

## What is CVE-2021-27578?

CVE-2021-27578 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross Site Scripting vulnerability in markdown interpreter of Apache Zeppelin allows an attacker to inject malicious scripts. This issue affects Apache Zeppelin Apache Zeppelin versions prior to 0.9.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-27578?

2 open source packages ship an affected version, including org.apache.zeppelin:zeppelin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.zeppelin:zeppelin` | Maven | All versions | 0.9.0 |
| `org.apache.zeppelin:zeppelin` | Maven | All versions | 0.9.0 |

Products: Apache Zeppelin.

## How do I fix CVE-2021-27578?

Upgrade org.apache.zeppelin:zeppelin to 0.9.0 or later.

## Is CVE-2021-27578 being exploited?

There is no known exploitation of CVE-2021-27578 in the wild and no public exploit code.

## Other vulnerabilities in Apache Zeppelin

- [CVE-2024-31864](https://insights.sbomify.com/CVE-2024-31864/): Apache Zeppelin: Remote code execution by adding malicious JDBC connection string (critical 9.8)
- [CVE-2024-31866](https://insights.sbomify.com/CVE-2024-31866/): Apache Zeppelin: Interpreter download command does not escape malicious code injection (critical 9.8)
- [CVE-2019-10095](https://insights.sbomify.com/CVE-2019-10095/): bash command injection in spark interpreter (critical 9.8)
- [CVE-2018-1317](https://insights.sbomify.com/CVE-2018-1317/): Improper Authentication in Apache Zeppelin (high 8.8)
- [CVE-2017-12619](https://insights.sbomify.com/CVE-2017-12619/): Session Fixation in Apache Zeppelin (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27578 and fix it if it is affected.

What it is: CVE-2021-27578 is a medium-severity cross-site scripting vulnerability in Apache Zeppelin, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27578 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.zeppelin:zeppelin (Maven): affected all versions; fixed in 0.9.0
- org.apache.zeppelin:zeppelin (Maven): affected all versions; fixed in 0.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27578/ (Markdown: https://insights.sbomify.com/CVE-2021-27578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27578
- OSV: https://osv.dev/vulnerability/CVE-2021-27578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27578/
Summaries are generated and may contain mistakes; the official description above is the record.
