CVE-2021-27850 Bypass of the fix for CVE-2019-0195
Attackers can bypass a blacklist to retrieve HMAC keys and execute arbitrary code via deserialization in Apache Tapestry.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-27850?
CVE-2021-27850 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A critical unauthenticated remote code execution vulnerability was found all recent versions of Apache Tapestry. The affected versions include 5.4.5, 5.5.0, 5.6.2 and 5.7.0. The vulnerability I have found is a bypass of the fix for CVE-2019-0195. Recap: Before the fix of CVE-2019-0195 it was possible to download arbitrary class files from the classpath by providing a crafted asset file URL. An attacker was able to download the file `AppModule.class` by requesting the URL `http://localhost:8080/assets/something/services/AppModule.class` which contains a HMAC secret key. The fix for that bug was a blacklist filter that checks if the URL ends with `.class`, `.properties` or `.xml`. Bypass: Unfortunately, the blacklist solution can simply be bypassed by appending a `/` at the end of the URL: `http://localhost:8080/assets/something/services/AppModule.class/` The slash is stripped after the blacklist check and the file `AppModule.class` is loaded into the response. This class usually contains the HMAC secret key which is used to sign serialized Java objects. With the knowledge of that key an attacker can sign a Java gadget chain that leads to RCE (e.g. CommonsBeanUtils1 from ysoserial). Solution for this vulnerability: * For Apache Tapestry 5.4.0 to 5.6.1, upgrade to 5.6.2 or later. * For Apache Tapestry 5.7.0, upgrade to 5.7.1 or later.
Which versions are affected by CVE-2021-27850?
4 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tapestry:tapestry-core Maven | From 5.4.0 | 5.6.3 |
org.apache.tapestry:tapestry-core Maven | From 5.4.0 | 5.6.3 |
org.apache.tapestry:tapestry-core Maven | From 5.7.0 | 5.7.1 |
org.apache.tapestry:tapestry-core Maven | From 5.7.0 | 5.7.1 |
Products include Apache Tapestry.
How do I fix CVE-2021-27850?
Upgrade org.apache.tapestry:tapestry-core to a fixed version for your release line: 5.6.3 or 5.7.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2021-27850 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-27850 exists.
Public exploit code: 1 Metasploit module, 1 Nuclei template and 4 proofs of concept on GitHub.
Other vulnerabilities in Apache Tapestry
- CVE-2022-46366 Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input
- CVE-2020-17531 Deserialization flaw in EOL Tapestry 4.
- CVE-2019-0195 Deserialization of Untrusted Data in Apache Tapestry
- CVE-2019-10071 Timing attack on HMAC signature comparison in Apache Tapestry
- CVE-2014-1972 Apache Tapestry Unsafe Object Storage
Sources
Also known as GHSA-mj8x-cpr8-x39h.