# CVE-2021-27850: Bypass of the fix for CVE-2019-0195

> Attackers can bypass a blacklist to retrieve HMAC keys and execute arbitrary code via deserialization in Apache Tapestry.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-mj8x-cpr8-x39h

## What is CVE-2021-27850?

CVE-2021-27850 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A critical unauthenticated remote code execution vulnerability was found all recent versions of Apache Tapestry. The affected versions include 5.4.5, 5.5.0, 5.6.2 and 5.7.0. The vulnerability I have found is a bypass of the fix for CVE-2019-0195. Recap: Before the fix of CVE-2019-0195 it was possible to download arbitrary class files from the classpath by providing a crafted asset file URL. An attacker was able to download the file `AppModule.class` by requesting the URL `http://localhost:8080/assets/something/services/AppModule.class` which contains a HMAC secret key. The fix for that bug was a blacklist filter that checks if the URL ends with `.class`, `.properties` or `.xml`. Bypass: Unfortunately, the blacklist solution can simply be bypassed by appending a `/` at the end of the URL: `http://localhost:8080/assets/something/services/AppModule.class/` The slash is stripped after the blacklist check and the file `AppModule.class` is loaded into the response. This class usually contains the HMAC secret key which is used to sign serialized Java objects. With the knowledge of that key an attacker can sign a Java gadget chain that leads to RCE (e.g. CommonsBeanUtils1 from ysoserial). Solution for this vulnerability: * For Apache Tapestry 5.4.0 to 5.6.1, upgrade to 5.6.2 or later. * For Apache Tapestry 5.7.0, upgrade to 5.7.1 or later.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-27850?

4 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.4.0 | 5.6.3 |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.4.0 | 5.6.3 |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.7.0 | 5.7.1 |
| `org.apache.tapestry:tapestry-core` | Maven | From 5.7.0 | 5.7.1 |

Products: Apache Tapestry.

## How do I fix CVE-2021-27850?

Upgrade org.apache.tapestry:tapestry-core to a fixed version for your release line: 5.6.3 or 5.7.1.

## Is CVE-2021-27850 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-27850 exists.

Public exploit code:

- A Proof of concept for CVE-2021-27850 affecting Apache Tapestry and leading to unauthencticated remote code execution. (github_poc): https://github.com/kahla-sec/CVE-2021-27850_POC
- A Proof of concept for CVE-2021-27850 affecting Apache Tapestry and leading to unauthencticated remote code execution. (github_poc): https://github.com/dorkerdevil/CVE-2021-27850_POC
- Apache Tapestry CVE-2021-27850 PoC (github_poc): https://github.com/Ovi3/CVE_2021_27850_POC
- Apache Tapestry HMAC secret key leak (metasploit)
- CVE-2021-27850 ysoserial (github_poc): https://github.com/novysodope/CVE-2021-27850
- Apache Tapestry - Remote Code Execution (nuclei): http/cves/2021/CVE-2021-27850.yaml

## Other vulnerabilities in Apache Tapestry

- [CVE-2022-46366](https://insights.sbomify.com/CVE-2022-46366/): Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input (critical 9.8)
- [CVE-2020-17531](https://insights.sbomify.com/CVE-2020-17531/): Deserialization flaw in EOL Tapestry 4. (critical 9.8)
- [CVE-2019-0195](https://insights.sbomify.com/CVE-2019-0195/): Deserialization of Untrusted Data in Apache Tapestry (critical 9.8)
- [CVE-2019-10071](https://insights.sbomify.com/CVE-2019-10071/): Timing attack on HMAC signature comparison in Apache Tapestry (critical 9.8)
- [CVE-2014-1972](https://insights.sbomify.com/CVE-2014-1972/): Apache Tapestry Unsafe Object Storage (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27850 and fix it if it is affected.

What it is: CVE-2021-27850 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 15 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-27850 exists.

Affected packages and fixed versions:
- org.apache.tapestry:tapestry-core (Maven): affected from 5.4.0; fixed in 5.6.3
- org.apache.tapestry:tapestry-core (Maven): affected from 5.4.0; fixed in 5.6.3
- org.apache.tapestry:tapestry-core (Maven): affected from 5.7.0; fixed in 5.7.1
- org.apache.tapestry:tapestry-core (Maven): affected from 5.7.0; fixed in 5.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27850/ (Markdown: https://insights.sbomify.com/CVE-2021-27850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27850
- OSV: https://osv.dev/vulnerability/CVE-2021-27850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27850/
Summaries are generated and may contain mistakes; the official description above is the record.
