# CVE-2021-27884: Weak JSON Web Token in yapi-vendor

> Weak JWT secret generation allows attackers to forge tokens and take over other users' accounts in YApi.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-2h3h-vw8r-82rp

## What is CVE-2021-27884?

CVE-2021-27884 is a medium-severity vulnerability in n/a, published on 1 Mar 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Weak JSON Web Token (JWT) signing secret generation in YMFE YApi through 1.9.2 allows recreation of other users' JWT tokens. This occurs because Math.random in Node.js is used.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2021-27884?

2 open source packages ship an affected version, including yapi-vendor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yapi-vendor` | npm | All versions | 1.9.3 |
| `yapi-vendor` | npm | All versions | 1.9.3 |

Products: Ymfe Yapi.

## How do I fix CVE-2021-27884?

Upgrade yapi-vendor to 1.9.3 or later.

## Is CVE-2021-27884 being exploited?

There is no known exploitation of CVE-2021-27884 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-70059](https://insights.sbomify.com/CVE-2025-70059/): Denial of service in n/a (high 7.5)
- [CVE-2025-70058](https://insights.sbomify.com/CVE-2025-70058/): yapi disables TLS/SSL certificate validation via rejectUnauthorized: false in Axios HTTPS agent (high 7.4)
- [CVE-2025-70060](https://insights.sbomify.com/CVE-2025-70060/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2021-36686](https://insights.sbomify.com/CVE-2021-36686/): Cross-site Scripting in yapi-vendor (medium 5.4)
- [CVE-2018-17574](https://insights.sbomify.com/CVE-2018-17574/): Cross-site Scripting in yapi-vendor (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27884 and fix it if it is affected.

What it is: CVE-2021-27884 is a medium-severity vulnerability in n/a, published on 1 Mar 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27884 in the wild and no public exploit code.

Affected packages and fixed versions:
- yapi-vendor (npm): affected all versions; fixed in 1.9.3
- yapi-vendor (npm): affected all versions; fixed in 1.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27884/ (Markdown: https://insights.sbomify.com/CVE-2021-27884/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27884
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27884
- OSV: https://osv.dev/vulnerability/CVE-2021-27884

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27884/
Summaries are generated and may contain mistakes; the official description above is the record.
