# CVE-2021-27905: SSRF vulnerability with the Replication handler

> Attackers can exploit the ReplicationHandler to perform Server-Side Request Forgery, accessing internal resources or bypassing network restrictions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-solr-2021-27905, DEBIAN-CVE-2021-27905, GHSA-5phw-3jrp-3vj8, UBUNTU-CVE-2021-27905

## What is CVE-2021-27905?

CVE-2021-27905 is a critical server-side request forgery vulnerability in Apache Solr, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The ReplicationHandler (normally registered at "/replication" under a Solr core) in Apache Solr has a "masterUrl" (also "leaderUrl" alias) parameter that is used to designate another ReplicationHandler on another Solr core to replicate index data into the local core. To prevent a SSRF vulnerability, Solr ought to check these parameters against a similar configuration it uses for the "shards" parameter. Prior to this bug getting fixed, it did not. This problem affects essentially all Solr versions prior to it getting fixed in 8.8.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2021-27905?

3 open source packages ship an affected version, including org.apache.solr:solr-parent and solr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.solr:solr-parent` | Maven | All versions | 8.8.2 |
| `org.apache.solr:solr-parent` | Maven | All versions | 8.8.2 |
| `solr` | Bitnami | All versions | 8.8.2 |

Products: Apache Solr.

## How do I fix CVE-2021-27905?

Upgrade org.apache.solr:solr-parent to 8.8.2 or later.

## Is CVE-2021-27905 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-27905 exists.

Public exploit code:

- Apache Solr SSRF(CVE-2021-27905) (github_poc): https://github.com/Henry4E36/Solr-SSRF
- [CVE-2021-27905] Apache Solr ReplicationHandler Server Side Request Forgery (SSRF) (github_poc): https://github.com/murataydemir/CVE-2021-27905
- POC for LFI related to CVE-2021-27905 (github_poc): https://github.com/pdelteil/CVE-2021-27905.POC
- Apache Solr < 8.8.2 Server Side Request Forgery (github_poc): https://github.com/RIZZZIOM/CVE-2021-27905
- CVE-2021-27905 (github_poc): https://github.com/W2Ning/Solr-SSRF
- Apache Solr <=8.8.1 - Server-Side Request Forgery (nuclei): http/cves/2021/CVE-2021-27905.yaml

## Other vulnerabilities in Apache Solr

- [CVE-2019-17558](https://insights.sbomify.com/CVE-2019-17558/): Apache Solr VelocityResponseWriter Plug-In Remote Code Execution (high 7.5, exploited in the wild)
- [CVE-2019-0193](https://insights.sbomify.com/CVE-2019-0193/): Apache Solr DataImportHandler Code Injection (high 7.2, exploited in the wild)
- [CVE-2024-45216](https://insights.sbomify.com/CVE-2024-45216/): Apache Solr: Authentication bypass possible using a fake URL Path ending (critical 9.8)
- [CVE-2021-44548](https://insights.sbomify.com/CVE-2021-44548/): Apache Solr information disclosure vulnerability through DataImportHandler (critical 9.8)
- [CVE-2020-13957](https://insights.sbomify.com/CVE-2020-13957/): Incorrect Authorization in Apache Solr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27905 and fix it if it is affected.

What it is: CVE-2021-27905 is a critical server-side request forgery vulnerability in Apache Solr, published on 13 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-27905 exists.

Affected packages and fixed versions:
- org.apache.solr:solr-parent (Maven): affected all versions; fixed in 8.8.2
- org.apache.solr:solr-parent (Maven): affected all versions; fixed in 8.8.2
- solr (Bitnami): affected all versions; fixed in 8.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27905/ (Markdown: https://insights.sbomify.com/CVE-2021-27905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27905
- OSV: https://osv.dev/vulnerability/CVE-2021-27905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27905/
Summaries are generated and may contain mistakes; the official description above is the record.
