# CVE-2021-27907: Apache Superset stored XSS on Dashboard markdown

> A malicious user can inject JavaScript into Superset dashboards via Markdown components, leading to stored XSS and potential account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-superset-2021-27907, GHSA-w358-rj93-r5qv, PYSEC-2021-127

## What is CVE-2021-27907?

CVE-2021-27907 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 5 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Apache Superset up to and including 0.38.0 allowed the creation of a Markdown component on a Dashboard page for describing chart's related information. Abusing this functionality, a malicious user could inject javascript code executing unwanted action in the context of the user's browser. The javascript code will be automatically executed (Stored XSS) when a legitimate user surfs on the dashboard page. The vulnerability is exploitable creating a “div” section and embedding in it a “svg” element with javascript code.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-27907?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 0.38.1 |
| `apache-superset` | PyPI | All versions | 0.38.1 |
| `apache-superset` | PyPI | All versions | 0.38.1 |
| `superset` | Bitnami | All versions | 0.38.1 |

Products: Apache Superset.

## How do I fix CVE-2021-27907?

Upgrade apache-superset to 0.38.1 or later.

## Is CVE-2021-27907 being exploited?

There is no known exploitation of CVE-2021-27907 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27907 and fix it if it is affected.

What it is: CVE-2021-27907 is a medium-severity cross-site scripting vulnerability in Apache Superset, published on 5 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27907 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 0.38.1
- apache-superset (PyPI): affected all versions; fixed in 0.38.1
- apache-superset (PyPI): affected all versions; fixed in 0.38.1
- superset (Bitnami): affected all versions; fixed in 0.38.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27907/ (Markdown: https://insights.sbomify.com/CVE-2021-27907/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27907
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27907
- OSV: https://osv.dev/vulnerability/CVE-2021-27907

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27907/
Summaries are generated and may contain mistakes; the official description above is the record.
