# CVE-2021-27908: Mautic vulnerable to secret data exfiltration via symfony parameters

> An authorized admin can expose sensitive database credentials by injecting Symfony parameter syntax into public configuration fields.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Mar 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4hjq-422q-4vpx

## What is CVE-2021-27908?

CVE-2021-27908 is a medium-severity vulnerability in Mautic, published on 23 Mar 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In all versions prior to Mautic 3.3.2, secret parameters such as database credentials could be exposed publicly by an authorized admin user through leveraging Symfony parameter syntax in any of the free text fields in Mautic’s configuration that are used in publicly facing parts of the application.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-27908?

2 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | All versions | 3.3.2 |
| `mautic/core` | Packagist | All versions | 3.3.2 |

Products: Acquia Mautic.

## How do I fix CVE-2021-27908?

Upgrade mautic/core to 3.3.2 or later.

## Is CVE-2021-27908 being exploited?

There is no known exploitation of CVE-2021-27908 in the wild and no public exploit code.

## Other vulnerabilities in Mautic

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2024-47051](https://insights.sbomify.com/CVE-2024-47051/): Remote Code Execution & File Deletion in Asset Uploads (critical 9.1)
- [CVE-2020-35128](https://insights.sbomify.com/CVE-2020-35128/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27908 and fix it if it is affected.

What it is: CVE-2021-27908 is a medium-severity vulnerability in Mautic, published on 23 Mar 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27908 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected all versions; fixed in 3.3.2
- mautic/core (Packagist): affected all versions; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27908/ (Markdown: https://insights.sbomify.com/CVE-2021-27908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27908
- OSV: https://osv.dev/vulnerability/CVE-2021-27908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27908/
Summaries are generated and may contain mistakes; the official description above is the record.
