CVE-2021-27909 XSS vulnerability on password reset page

Medium 6.3 Published Updated

An attacker can execute JavaScript on the password reset page via a vulnerable URL parameter, requiring user interaction to trigger.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-27909?

CVE-2021-27909 is a medium-severity cross-site scripting vulnerability in Mautic, published on 30 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

For Mautic versions prior to 3.3.4/4.0.0, there is an XSS vulnerability on Mautic's password reset page where a vulnerable parameter, "bundle," in the URL could allow an attacker to execute Javascript code. The attacker would be required to convince or trick the target into clicking a password reset URL with the vulnerable parameter utilized.

Weakness: CWE-79

Which versions are affected by CVE-2021-27909?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.

PackageAffectedFixed in
mautic/core PackagistAll versions3.3.4
mautic/core PackagistAll versions3.3.4
mautic/core PackagistFrom 4.0.0-alpha14.0.0
mautic/core PackagistFrom 4.0.0-alpha14.0.0

Products include Acquia Mautic.

How do I fix CVE-2021-27909?

Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-27909 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-27909 exists.

Public exploit code: 1 Nuclei template.

Sources

Also known as GHSA-32hw-3pvh-vcvc.

Is CVE-2021-27909 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free