CVE-2021-27911 XSS vulnerability on contacts view

High 8.3 Published Updated

An attacker can inject malicious JavaScript via contact names, leading to code execution or account takeover when viewing contact details.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-27911?

CVE-2021-27911 is a high-severity cross-site scripting vulnerability in Mautic, published on 30 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack through the contact's first or last name and triggered when viewing a contact's details page then clicking on the action drop down and hovering over the Campaigns button. Contact first and last name can be populated from different sources such as UI, API, 3rd party syncing, forms, etc.

Weakness: CWE-79

Which versions are affected by CVE-2021-27911?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.

PackageAffectedFixed in
mautic/core PackagistAll versions3.3.4
mautic/core PackagistAll versions3.3.4
mautic/core PackagistFrom 4.0.0-alpha14.0.0
mautic/core PackagistFrom 4.0.0-alpha14.0.0

Products include Acquia Mautic.

How do I fix CVE-2021-27911?

Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-27911 being exploited?

There is no known exploitation of CVE-2021-27911 in the wild and no public exploit code.

Sources

Also known as GHSA-72hm-fx78-xwhc.

Is CVE-2021-27911 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free