CVE-2021-27912 XSS vulnerability on asset view

High 7.1 Published Updated

Authenticated users with asset permissions can execute arbitrary JavaScript via inline JS in asset titles, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-27912?

CVE-2021-27912 is a high-severity cross-site scripting vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title and adding a broken image URL as a remote asset. This can only be leveraged by an authenticated user with permission to create or edit assets.

Weakness: CWE-79

Which versions are affected by CVE-2021-27912?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.

PackageAffectedFixed in
mautic/core PackagistAll versions3.3.4
mautic/core PackagistAll versions3.3.4
mautic/core PackagistFrom 4.0.0-alpha14.0.0
mautic/core PackagistFrom 4.0.0-alpha14.0.0

Products include Acquia Mautic.

How do I fix CVE-2021-27912?

Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-27912 being exploited?

There is no known exploitation of CVE-2021-27912 in the wild and no public exploit code.

Sources

Also known as GHSA-rh5w-82wh-jhr8.

Is CVE-2021-27912 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free