# CVE-2021-27912: XSS vulnerability on asset view

> Authenticated users with asset permissions can execute arbitrary JavaScript via inline JS in asset titles, potentially leading to session hijacking or code execution.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rh5w-82wh-jhr8

## What is CVE-2021-27912?

CVE-2021-27912 is a high-severity cross-site scripting vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Mautic versions before 3.3.4/4.0.0 are vulnerable to an inline JS XSS attack when viewing Mautic assets by utilizing inline JS in the title and adding a broken image URL as a remote asset. This can only be leveraged by an authenticated user with permission to create or edit assets.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-27912?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | All versions | 3.3.4 |
| `mautic/core` | Packagist | All versions | 3.3.4 |
| `mautic/core` | Packagist | From 4.0.0-alpha1 | 4.0.0 |
| `mautic/core` | Packagist | From 4.0.0-alpha1 | 4.0.0 |

Products: Acquia Mautic.

## How do I fix CVE-2021-27912?

Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.

## Is CVE-2021-27912 being exploited?

There is no known exploitation of CVE-2021-27912 in the wild and no public exploit code.

## Other vulnerabilities in Mautic

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2024-47051](https://insights.sbomify.com/CVE-2024-47051/): Remote Code Execution & File Deletion in Asset Uploads (critical 9.1)
- [CVE-2020-35128](https://insights.sbomify.com/CVE-2020-35128/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27912 and fix it if it is affected.

What it is: CVE-2021-27912 is a high-severity cross-site scripting vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27912 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected all versions; fixed in 3.3.4
- mautic/core (Packagist): affected all versions; fixed in 3.3.4
- mautic/core (Packagist): affected from 4.0.0-alpha1; fixed in 4.0.0
- mautic/core (Packagist): affected from 4.0.0-alpha1; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27912/ (Markdown: https://insights.sbomify.com/CVE-2021-27912/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27912
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27912
- OSV: https://osv.dev/vulnerability/CVE-2021-27912

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27912/
Summaries are generated and may contain mistakes; the official description above is the record.
