CVE-2021-27913 Use of a Broken or Risky Cryptographic Algorithm

Low 3.5 Published Updated

Attackers can enumerate session tokens due to insecure random number generation, potentially taking over user accounts in Mautic.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-27913?

CVE-2021-27913 is a low-severity vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

The function mt_rand is used to generate session tokens, this function is cryptographically flawed due to its nature being one pseudorandomness, an attacker can take advantage of the cryptographically insecure nature of this function to enumerate session tokens for accounts that are not under his/her control This issue affects: Mautic Mautic versions prior to 3.3.4; versions prior to 4.0.0.

Weakness: CWE-338, CWE-327

Which versions are affected by CVE-2021-27913?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.

PackageAffectedFixed in
mautic/core PackagistAll versions3.3.4
mautic/core PackagistAll versions3.3.4
mautic/core PackagistFrom 4.0.0-alpha14.0.0
mautic/core PackagistFrom 4.0.0-alpha14.0.0

Products include Acquia Mautic.

How do I fix CVE-2021-27913?

Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.

Is CVE-2021-27913 being exploited?

There is no known exploitation of CVE-2021-27913 in the wild and no public exploit code.

Sources

Also known as GHSA-x7g2-wrrp-r6h3.

Is CVE-2021-27913 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free