{"answers":{"affected":"4 open source packages ship an affected version, including mautic/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-27913 in the wild and no public exploit code.","fix":"Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.","what":"CVE-2021-27913 is a low-severity vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-27913 and fix it if it is affected.\n\nWhat it is: CVE-2021-27913 is a low-severity vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-27913 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mautic/core (Packagist): affected all versions; fixed in 3.3.4\n- mautic/core (Packagist): affected all versions; fixed in 3.3.4\n- mautic/core (Packagist): affected from 4.0.0-alpha1; fixed in 4.0.0\n- mautic/core (Packagist): affected from 4.0.0-alpha1; fixed in 4.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-27913/ (Markdown: https://insights.sbomify.com/CVE-2021-27913/index.md)","id":"CVE-2021-27913","markdown":"https://insights.sbomify.com/CVE-2021-27913/index.md","name":"CVE-2021-27913","record":{"aliases":["GHSA-x7g2-wrrp-r6h3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Mautic marketing automation","requires_auth":"low_privilege","summary":"Attackers can enumerate session tokens due to insecure random number generation, potentially taking over user accounts in Mautic.","user_interaction":"required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mautic","cpe":[{"product":"mautic","vendor":"acquia"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-338","name":"Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)"},{"id":"CWE-327","name":"Use of a Broken or Risky Cryptographic Algorithm"}],"description":"The function mt_rand is used to generate session tokens, this function is cryptographically flawed due to its nature being one pseudorandomness, an attacker can take advantage of the cryptographically insecure nature of this function to enumerate session tokens for accounts that are not under his/her control This issue affects: Mautic Mautic versions prior to 3.3.4; versions prior to 4.0.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Use of a Broken or Risky Cryptographic Algorithm","id":"CVE-2021-27913","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"weak_cryptography","year":"2021"},"n_packages":4,"n_references":1,"next":{"headline":"Cross-site scripting in Mautic","id":"CVE-2021-27914"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.4"],"introduced":["0"],"last_affected":[],"package":"mautic/core","purl":null,"source":"GHSA-x7g2-wrrp-r6h3"},{"ecosystem":"Packagist","fixed":["3.3.4"],"introduced":["0"],"last_affected":[],"package":"mautic/core","purl":"pkg:composer/mautic/core","source":"GHSA-x7g2-wrrp-r6h3"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["4.0.0-alpha1"],"last_affected":[],"package":"mautic/core","purl":null,"source":"GHSA-x7g2-wrrp-r6h3"},{"ecosystem":"Packagist","fixed":["4.0.0"],"introduced":["4.0.0-alpha1"],"last_affected":[],"package":"mautic/core","purl":"pkg:composer/mautic/core","source":"GHSA-x7g2-wrrp-r6h3"}],"prev":{"headline":"XSS vulnerability on asset view","id":"CVE-2021-27912"},"products":["Mautic"],"published":"2021-08-30","related":[{"cvss_score":9.6,"headline":"Cross-site Scripting vulnerability in Mautic's tracking pixel functionality","id":"CVE-2022-25772","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":9.6,"headline":"Mautic is vulnerable to XSS vulnerability","id":"CVE-2020-35125","kev_date_added":null,"published":"2021-02-09"},{"cvss_score":9.6,"headline":"XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic","id":"CVE-2020-35124","kev_date_added":null,"published":"2021-01-28"},{"cvss_score":9.1,"headline":"Remote Code Execution \u0026 File Deletion in Asset Uploads","id":"CVE-2024-47051","kev_date_added":null,"published":"2025-02-26"},{"cvss_score":9,"headline":"Mautic stored Cross-site Scripting (XSS)","id":"CVE-2020-35128","kev_date_added":null,"published":"2021-01-19"},{"cvss_score":8.8,"headline":"Mautic Cross-Site Request Forgery (CSRF)","id":"CVE-2017-8874","kev_date_added":null,"published":"2017-05-10"},{"cvss_score":8.3,"headline":"Sensitive Data Exposure due to inadequate user permission settings","id":"CVE-2022-25776","kev_date_added":null,"published":"2024-09-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Mautic"]},"summary":"Attackers can enumerate session tokens due to insecure random number generation, potentially taking over user accounts in Mautic.","url":"https://insights.sbomify.com/CVE-2021-27913/"}