# CVE-2021-27913: Use of a Broken or Risky Cryptographic Algorithm

> Attackers can enumerate session tokens due to insecure random number generation, potentially taking over user accounts in Mautic.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-x7g2-wrrp-r6h3

## What is CVE-2021-27913?

CVE-2021-27913 is a low-severity vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

The function mt_rand is used to generate session tokens, this function is cryptographically flawed due to its nature being one pseudorandomness, an attacker can take advantage of the cryptographically insecure nature of this function to enumerate session tokens for accounts that are not under his/her control This issue affects: Mautic Mautic versions prior to 3.3.4; versions prior to 4.0.0.

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)), CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2021-27913?

4 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | All versions | 3.3.4 |
| `mautic/core` | Packagist | All versions | 3.3.4 |
| `mautic/core` | Packagist | From 4.0.0-alpha1 | 4.0.0 |
| `mautic/core` | Packagist | From 4.0.0-alpha1 | 4.0.0 |

Products: Acquia Mautic.

## How do I fix CVE-2021-27913?

Upgrade mautic/core to a fixed version for your release line: 3.3.4 or 4.0.0.

## Is CVE-2021-27913 being exploited?

There is no known exploitation of CVE-2021-27913 in the wild and no public exploit code.

## Other vulnerabilities in Mautic

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2024-47051](https://insights.sbomify.com/CVE-2024-47051/): Remote Code Execution & File Deletion in Asset Uploads (critical 9.1)
- [CVE-2020-35128](https://insights.sbomify.com/CVE-2020-35128/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27913 and fix it if it is affected.

What it is: CVE-2021-27913 is a low-severity vulnerability in Mautic, published on 30 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27913 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected all versions; fixed in 3.3.4
- mautic/core (Packagist): affected all versions; fixed in 3.3.4
- mautic/core (Packagist): affected from 4.0.0-alpha1; fixed in 4.0.0
- mautic/core (Packagist): affected from 4.0.0-alpha1; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27913/ (Markdown: https://insights.sbomify.com/CVE-2021-27913/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27913
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27913
- OSV: https://osv.dev/vulnerability/CVE-2021-27913

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27913/
Summaries are generated and may contain mistakes; the official description above is the record.
