{"answers":{"affected":"2 open source packages ship an affected version, including mautic/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-27915 in the wild and no public exploit code.","fix":"Upgrade mautic/core to 4.4.12 or later.","what":"CVE-2021-27915 is a high-severity cross-site scripting vulnerability in Mautic, published on 17 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-27915 and fix it if it is affected.\n\nWhat it is: CVE-2021-27915 is a high-severity cross-site scripting vulnerability in Mautic, published on 17 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-27915 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mautic/core (Packagist): affected from 1.0.0-beta2; fixed in 4.4.12\n- mautic/core (Packagist): affected from 1.0.0-beta2; fixed in 4.4.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-27915/ (Markdown: https://insights.sbomify.com/CVE-2021-27915/index.md)","id":"CVE-2021-27915","markdown":"https://insights.sbomify.com/CVE-2021-27915/index.md","name":"CVE-2021-27915","record":{"aliases":["GHSA-2rc5-2755-v422"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mautic marketing automation","requires_auth":"low_privilege","summary":"A stored XSS vulnerability in Mautic's description fields allows logged-in users to execute scripts, potentially leading to elevated system access.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mautic","cpe":[{"product":"mautic","vendor":"acquia"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.\n\nThis could lead to the user having elevated access to the system.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS Cross-site Scripting Stored (XSS) - Description field","id":"CVE-2021-27915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Relative Path Traversal / Arbitrary File Deletion in Mautic (GrapesJS Builder)","id":"CVE-2021-27916"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.12"],"introduced":["1.0.0-beta2"],"last_affected":[],"package":"mautic/core","purl":null,"source":"GHSA-2rc5-2755-v422"},{"ecosystem":"Packagist","fixed":["4.4.12"],"introduced":["1.0.0-beta2"],"last_affected":[],"package":"mautic/core","purl":"pkg:composer/mautic/core","source":"GHSA-2rc5-2755-v422"}],"prev":{"headline":"Cross-site scripting in Mautic","id":"CVE-2021-27914"},"products":["Mautic"],"published":"2024-09-17","related":[{"cvss_score":9.6,"headline":"Cross-site Scripting vulnerability in Mautic's tracking pixel functionality","id":"CVE-2022-25772","kev_date_added":null,"published":"2022-06-20"},{"cvss_score":9.6,"headline":"Mautic is vulnerable to XSS vulnerability","id":"CVE-2020-35125","kev_date_added":null,"published":"2021-02-09"},{"cvss_score":9.6,"headline":"XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic","id":"CVE-2020-35124","kev_date_added":null,"published":"2021-01-28"},{"cvss_score":9.1,"headline":"Remote Code Execution \u0026 File Deletion in Asset Uploads","id":"CVE-2024-47051","kev_date_added":null,"published":"2025-02-26"},{"cvss_score":9,"headline":"Mautic stored Cross-site Scripting (XSS)","id":"CVE-2020-35128","kev_date_added":null,"published":"2021-01-19"},{"cvss_score":8.8,"headline":"Mautic Cross-Site Request Forgery (CSRF)","id":"CVE-2017-8874","kev_date_added":null,"published":"2017-05-10"},{"cvss_score":8.3,"headline":"Sensitive Data Exposure due to inadequate user permission settings","id":"CVE-2022-25776","kev_date_added":null,"published":"2024-09-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Mautic"]},"summary":"A stored XSS vulnerability in Mautic's description fields allows logged-in users to execute scripts, potentially leading to elevated system access.","url":"https://insights.sbomify.com/CVE-2021-27915/"}