# CVE-2021-27915: XSS Cross-site Scripting Stored (XSS) - Description field

> A stored XSS vulnerability in Mautic's description fields allows logged-in users to execute scripts, potentially leading to elevated system access.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-2rc5-2755-v422

## What is CVE-2021-27915?

CVE-2021-27915 is a high-severity cross-site scripting vulnerability in Mautic, published on 17 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Prior to the patched version, there is an XSS vulnerability in the description fields within the Mautic application which could be exploited by a logged in user of Mautic with the appropriate permissions.

This could lead to the user having elevated access to the system.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2021-27915?

2 open source packages ship an affected version, including mautic/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | From 1.0.0-beta2 | 4.4.12 |
| `mautic/core` | Packagist | From 1.0.0-beta2 | 4.4.12 |

Products: Acquia Mautic.

## How do I fix CVE-2021-27915?

Upgrade mautic/core to 4.4.12 or later.

## Is CVE-2021-27915 being exploited?

There is no known exploitation of CVE-2021-27915 in the wild and no public exploit code.

## Other vulnerabilities in Mautic

- [CVE-2022-25772](https://insights.sbomify.com/CVE-2022-25772/): Cross-site Scripting vulnerability in Mautic's tracking pixel functionality (critical 9.6)
- [CVE-2020-35125](https://insights.sbomify.com/CVE-2020-35125/): Mautic is vulnerable to XSS vulnerability (critical 9.6)
- [CVE-2020-35124](https://insights.sbomify.com/CVE-2020-35124/): XSS vulnerability leveraged through referrers could allow un-authorized admin access in Mautic (critical 9.6)
- [CVE-2024-47051](https://insights.sbomify.com/CVE-2024-47051/): Remote Code Execution & File Deletion in Asset Uploads (critical 9.1)
- [CVE-2020-35128](https://insights.sbomify.com/CVE-2020-35128/): Mautic stored Cross-site Scripting (XSS) (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27915 and fix it if it is affected.

What it is: CVE-2021-27915 is a high-severity cross-site scripting vulnerability in Mautic, published on 17 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-27915 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected from 1.0.0-beta2; fixed in 4.4.12
- mautic/core (Packagist): affected from 1.0.0-beta2; fixed in 4.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27915/ (Markdown: https://insights.sbomify.com/CVE-2021-27915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27915
- OSV: https://osv.dev/vulnerability/CVE-2021-27915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27915/
Summaries are generated and may contain mistakes; the official description above is the record.
