# CVE-2021-27918: Denial of service in n/a

> An attacker can cause a denial of service via an infinite loop in the Go XML decoder when using a custom TokenReader that returns EOF prematurely.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-79104, AZL-98703, BIT-golang-2021-27918, DEBIAN-CVE-2021-27918, GHSA-8mmp-c685-53vw, GO-2021-0234, OESA-2021-1184, SUSE-SU-2021:0938-1, UBUNTU-CVE-2021-27918, openSUSE-SU-2021:0480-1

## What is CVE-2021-27918?

CVE-2021-27918 is a high-severity denial of service vulnerability in Golang Go, published on 10 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

encoding/xml in Go before 1.15.9 and 1.16.x before 1.16.1 has an infinite loop if a custom TokenReader (for xml.NewTokenDecoder) returns EOF in the middle of an element. This can occur in the Decode, DecodeElement, or Skip method.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2021-27918?

2 open source packages ship an affected version, including golang and stdlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.15.9, 1.16.1 |
| `stdlib` | Go | All versions | 1.15.9, 1.16.1 |
| `go1.15` | SUSE:Enterprise Storage 6 | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Manager Proxy 4.0 | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Manager Retail Branch Server 4.0 | All versions | 1.15.10-1.25.1 |
| `go1.15` | SUSE:Manager Server 4.0 | All versions | 1.15.10-1.25.1 |
| `go1.15` | openSUSE:Leap 15.2 | All versions | 1.15.10-lp152.14.1 |

Products: Golang Go.

## How do I fix CVE-2021-27918?

Upgrade golang to a fixed version for your release line: 1.15.9 or 1.16.1.

## Is CVE-2021-27918 being exploited?

There is no known exploitation of CVE-2021-27918 in the wild and no public exploit code.

## Other vulnerabilities in Golang Go

- [CVE-2020-0601](https://insights.sbomify.com/CVE-2020-0601/): Microsoft Windows CryptoAPI Spoofing (high 8.1, exploited in the wild)
- [CVE-2026-27143](https://insights.sbomify.com/CVE-2026-27143/): Missing bound checks can lead to memory corruption in safe Go in cmd/compile (critical 9.8)
- [CVE-2024-24790](https://insights.sbomify.com/CVE-2024-24790/): Unexpected behavior from Is methods for IPv4-mapped IPv6 addresses in net/netip (critical 9.8)
- [CVE-2023-39320](https://insights.sbomify.com/CVE-2023-39320/): Arbitrary code execution via go.mod toolchain directive in cmd/go (critical 9.8)
- [CVE-2023-24540](https://insights.sbomify.com/CVE-2023-24540/): Improper handling of JavaScript whitespace in html/template (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27918 and fix it if it is affected.

What it is: CVE-2021-27918 is a high-severity denial of service vulnerability in Golang Go, published on 10 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27918 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.15.9, 1.16.1
- stdlib (Go): affected all versions; fixed in 1.15.9, 1.16.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27918/ (Markdown: https://insights.sbomify.com/CVE-2021-27918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27918
- OSV: https://osv.dev/vulnerability/CVE-2021-27918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27918/
Summaries are generated and may contain mistakes; the official description above is the record.
