# CVE-2021-27921: Pillow Denial of Service by Uncontrolled Resource Consumption

> Attackers can cause denial of service via memory exhaustion in Pillow by exploiting improper size checks in BLP containers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2021
- **Updated:** 15 Aug 2025
- **Also known as:** ALPINE-CVE-2021-27921, BIT-pillow-2021-27921, DEBIAN-CVE-2021-27921, GHSA-f4w8-cv6p-x6r5, PYSEC-2021-40, ROOT-APP-PYPI-CVE-2021-27921, UBUNTU-CVE-2021-27921

## What is CVE-2021-27921?

CVE-2021-27921 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Pillow before 8.1.2 allows attackers to cause a denial of service (memory consumption) because the reported size of a contained image is not properly checked for a BLP container, and thus an attempted memory allocation can be very large.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-27921?

4 open source packages ship an affected version, including pillow and Pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 8.1.1 |
| `pillow` | PyPI | All versions | 8.1.1 |
| `pillow` | PyPI | All versions | 8.1.2 |
| `Pillow` | PyPI | All versions | 8.1.2 |

Products: Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2021-27921?

Upgrade pillow to a fixed version for your release line: 8.1.1 or 8.1.2.

## Is CVE-2021-27921 being exploited?

There is no known exploitation of CVE-2021-27921 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-27921 and fix it if it is affected.

What it is: CVE-2021-27921 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 3 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-27921 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 8.1.1
- pillow (PyPI): affected all versions; fixed in 8.1.1
- pillow (PyPI): affected all versions; fixed in 8.1.2
- Pillow (PyPI): affected all versions; fixed in 8.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-27921/ (Markdown: https://insights.sbomify.com/CVE-2021-27921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-27921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-27921
- OSV: https://osv.dev/vulnerability/CVE-2021-27921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-27921/
Summaries are generated and may contain mistakes; the official description above is the record.
