# CVE-2021-28027: Loading a bgzip block can write out of bounds if size overflows.

> An integer underflow in the bam crate allows out-of-bounds writes when loading bgzip blocks, potentially leading to code execution or crashes.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-cpqj-r29q-chrh, RUSTSEC-2021-0027

## What is CVE-2021-28027?

CVE-2021-28027 is a critical vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the bam crate before 0.1.3 for Rust. There is an integer underflow and out-of-bounds write during the loading of a bgzip block.

Weakness: CWE-191 (Integer Underflow (Wrap or Wraparound))

## Which versions are affected by CVE-2021-28027?

3 open source packages ship an affected version, including bam. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bam` | crates.io | All versions | 0.1.3 |
| `bam` | crates.io | All versions | 0.1.3 |
| `bam` | crates.io | From 0.0.0-0 | 0.1.3 |

Products: Bam Project Bam.

## How do I fix CVE-2021-28027?

Upgrade bam to 0.1.3 or later.

## Is CVE-2021-28027 being exploited?

There is no known exploitation of CVE-2021-28027 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28027 and fix it if it is affected.

What it is: CVE-2021-28027 is a critical vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28027 in the wild and no public exploit code.

Affected packages and fixed versions:
- bam (crates.io): affected all versions; fixed in 0.1.3
- bam (crates.io): affected all versions; fixed in 0.1.3
- bam (crates.io): affected from 0.0.0-0; fixed in 0.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28027/ (Markdown: https://insights.sbomify.com/CVE-2021-28027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28027
- OSV: https://osv.dev/vulnerability/CVE-2021-28027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28027/
Summaries are generated and may contain mistakes; the official description above is the record.
