# CVE-2021-28028: Double free in toodee

> A double free vulnerability in the toodee Rust library allows attackers to cause denial of service or potentially execute code via crafted row insertions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wcvp-r8j8-47pc

## What is CVE-2021-28028?

CVE-2021-28028 is a critical use after free vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the toodee crate before 0.3.0 for Rust. Row insertion can cause a double free upon an iterator panic.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2021-28028?

2 open source packages ship an affected version, including toodee. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toodee` | crates.io | All versions | 0.3.0 |
| `toodee` | crates.io | All versions | 0.3.0 |

Products: Toodee Project Toodee.

## How do I fix CVE-2021-28028?

Upgrade toodee to 0.3.0 or later.

## Is CVE-2021-28028 being exploited?

There is no known exploitation of CVE-2021-28028 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-28029](https://insights.sbomify.com/CVE-2021-28029/): Uninitialized memory access in toodee (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28028 and fix it if it is affected.

What it is: CVE-2021-28028 is a critical use after free vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28028 in the wild and no public exploit code.

Affected packages and fixed versions:
- toodee (crates.io): affected all versions; fixed in 0.3.0
- toodee (crates.io): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28028/ (Markdown: https://insights.sbomify.com/CVE-2021-28028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28028
- OSV: https://osv.dev/vulnerability/CVE-2021-28028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28028/
Summaries are generated and may contain mistakes; the official description above is the record.
