# CVE-2021-28029: Uninitialized memory access in toodee

> Attackers can read uninitialized memory contents via the row-insertion feature in the toodee Rust library, potentially exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xm9m-2vj8-fmfr

## What is CVE-2021-28029?

CVE-2021-28029 is a high-severity vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the toodee crate before 0.3.0 for Rust. The row-insertion feature allows attackers to read the contents of uninitialized memory locations.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2021-28029?

2 open source packages ship an affected version, including toodee. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toodee` | crates.io | All versions | 0.3.0 |
| `toodee` | crates.io | All versions | 0.3.0 |

Products: Toodee Project Toodee.

## How do I fix CVE-2021-28029?

Upgrade toodee to 0.3.0 or later.

## Is CVE-2021-28029 being exploited?

There is no known exploitation of CVE-2021-28029 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-28028](https://insights.sbomify.com/CVE-2021-28028/): Double free in toodee (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28029 and fix it if it is affected.

What it is: CVE-2021-28029 is a high-severity vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28029 in the wild and no public exploit code.

Affected packages and fixed versions:
- toodee (crates.io): affected all versions; fixed in 0.3.0
- toodee (crates.io): affected all versions; fixed in 0.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28029/ (Markdown: https://insights.sbomify.com/CVE-2021-28029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28029
- OSV: https://osv.dev/vulnerability/CVE-2021-28029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28029/
Summaries are generated and may contain mistakes; the official description above is the record.
