# CVE-2021-28031: move_elements can double-free objects on panic

> A double-free vulnerability in the Rust scratchpad crate allows attackers to cause denial of service or potentially execute code via a panic in a user-provided function.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3qm2-rfqw-fmrw, RUSTSEC-2021-0030

## What is CVE-2021-28031?

CVE-2021-28031 is a critical use after free vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the scratchpad crate before 1.3.1 for Rust. The move_elements function can have a double-free upon a panic in a user-provided f function.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2021-28031?

3 open source packages ship an affected version, including scratchpad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scratchpad` | crates.io | All versions | 1.3.1 |
| `scratchpad` | crates.io | All versions | 1.3.1 |
| `scratchpad` | crates.io | From 0.0.0-0 | 1.3.1 |

Products: Scratchpad Project Scratchpad.

## How do I fix CVE-2021-28031?

Upgrade scratchpad to 1.3.1 or later.

## Is CVE-2021-28031 being exploited?

There is no known exploitation of CVE-2021-28031 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28031 and fix it if it is affected.

What it is: CVE-2021-28031 is a critical use after free vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28031 in the wild and no public exploit code.

Affected packages and fixed versions:
- scratchpad (crates.io): affected all versions; fixed in 1.3.1
- scratchpad (crates.io): affected all versions; fixed in 1.3.1
- scratchpad (crates.io): affected from 0.0.0-0; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28031/ (Markdown: https://insights.sbomify.com/CVE-2021-28031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28031
- OSV: https://osv.dev/vulnerability/CVE-2021-28031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28031/
Summaries are generated and may contain mistakes; the official description above is the record.
