# CVE-2021-28035: Drop of uninitialized memory in stack_dst

> A memory corruption vulnerability in the Rust stack_dst crate allows denial of service via uninitialized memory drop during clone panics.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-45w7-7g63-2m5w

## What is CVE-2021-28035?

CVE-2021-28035 is a critical memory corruption vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the stack_dst crate before 0.6.1 for Rust. Because of the push_inner behavior, a drop of uninitialized memory can occur upon a val.clone() panic.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2021-28035?

2 open source packages ship an affected version, including stack_dst. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `stack_dst` | crates.io | All versions | 0.6.1 |
| `stack_dst` | crates.io | All versions | 0.6.1 |

Products: Stack Dst Project Stack Dst.

## How do I fix CVE-2021-28035?

Upgrade stack_dst to 0.6.1 or later.

## Is CVE-2021-28035 being exploited?

There is no known exploitation of CVE-2021-28035 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-28034](https://insights.sbomify.com/CVE-2021-28034/): Double free in stack_dst (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28035 and fix it if it is affected.

What it is: CVE-2021-28035 is a critical memory corruption vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28035 in the wild and no public exploit code.

Affected packages and fixed versions:
- stack_dst (crates.io): affected all versions; fixed in 0.6.1
- stack_dst (crates.io): affected all versions; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28035/ (Markdown: https://insights.sbomify.com/CVE-2021-28035/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28035
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28035
- OSV: https://osv.dev/vulnerability/CVE-2021-28035

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28035/
Summaries are generated and may contain mistakes; the official description above is the record.
