# CVE-2021-28037: Data race in internment

> A data race in the Rust internment crate can lead to memory corruption, potentially allowing arbitrary code execution.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gppw-3h6h-v6q2, RUSTSEC-2021-0036

## What is CVE-2021-28037?

CVE-2021-28037 is a critical vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the internment crate before 0.4.2 for Rust. There is a data race that can cause memory corruption because of the unconditional implementation of Sync for Intern<T>.

## Which versions are affected by CVE-2021-28037?

3 open source packages ship an affected version, including internment. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `internment` | crates.io | All versions | 0.4.2 |
| `internment` | crates.io | All versions | 0.4.2 |
| `internment` | crates.io | From 0.0.0-0 | 0.4.2 |

Products: Internment Project Internment.

## How do I fix CVE-2021-28037?

Upgrade internment to 0.4.2 or later.

## Is CVE-2021-28037 being exploited?

There is no known exploitation of CVE-2021-28037 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-35874](https://insights.sbomify.com/CVE-2020-35874/): Use after free in internment (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28037 and fix it if it is affected.

What it is: CVE-2021-28037 is a critical vulnerability in n/a, published on 5 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28037 in the wild and no public exploit code.

Affected packages and fixed versions:
- internment (crates.io): affected all versions; fixed in 0.4.2
- internment (crates.io): affected all versions; fixed in 0.4.2
- internment (crates.io): affected from 0.0.0-0; fixed in 0.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28037/ (Markdown: https://insights.sbomify.com/CVE-2021-28037/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28037
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28037
- OSV: https://osv.dev/vulnerability/CVE-2021-28037

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28037/
Summaries are generated and may contain mistakes; the official description above is the record.
