CVE-2021-28092 Regular Expression Denial of Service (ReDoS)

High 7.5 Published Updated

Attackers can cause denial of service in applications using the is-svg library by submitting malicious strings that trigger excessive CPU usage via ReDoS.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-28092?

CVE-2021-28092 is a high-severity denial of service vulnerability in n/a, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The is-svg package 2.1.0 through 4.2.1 for Node.js uses a regular expression that is vulnerable to Regular Expression Denial of Service (ReDoS). If an attacker provides a malicious string, is-svg will get stuck processing the input for a very long time.

Weakness: CWE-1333

Which versions are affected by CVE-2021-28092?

2 open source packages ship an affected version, including is-svg. It affects 1 product.

PackageAffectedFixed in
is-svg npmFrom 2.1.04.2.2
is-svg npmFrom 2.1.04.2.2

Products include Is-Svg Project Is-Svg.

How do I fix CVE-2021-28092?

Upgrade is-svg to 4.2.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-28092 being exploited?

There is no known exploitation of CVE-2021-28092 in the wild and no public exploit code.

Sources

Also known as GHSA-7r28-3m3f-r2pr, ROOT-APP-NPM-CVE-2021-28092.

Is CVE-2021-28092 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free