CVE-2021-28114 Cross-site Scripting in Froala WYSIWYG Editor

Medium 5.4 Published Updated

An attacker can execute arbitrary scripts in the victim's browser via namespace confusion in the Froala WYSIWYG Editor.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-28114?

CVE-2021-28114 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.

Weakness: CWE-79

Which versions are affected by CVE-2021-28114?

2 open source packages ship an affected version, including froala/wysiwyg-editor. It affects 1 product.

PackageAffectedFixed in
froala/wysiwyg-editor PackagistAll versions3.2.7
froala/wysiwyg-editor PackagistAll versions3.2.7

Products include Froala Froala Editor.

How do I fix CVE-2021-28114?

Upgrade froala/wysiwyg-editor to 3.2.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2021-28114 being exploited?

There is no known exploitation of CVE-2021-28114 in the wild and no public exploit code.

Sources

Also known as GHSA-rr6v-h7m8-wc9f.

Is CVE-2021-28114 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free