# CVE-2021-28114: Cross-site Scripting in Froala WYSIWYG Editor

> An attacker can execute arbitrary scripts in the victim's browser via namespace confusion in the Froala WYSIWYG Editor.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jul 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-rr6v-h7m8-wc9f

## What is CVE-2021-28114?

CVE-2021-28114 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Froala WYSIWYG Editor 3.2.6-1 is affected by XSS due to a namespace confusion during parsing.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-28114?

2 open source packages ship an affected version, including froala/wysiwyg-editor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froala/wysiwyg-editor` | Packagist | All versions | 3.2.7 |
| `froala/wysiwyg-editor` | Packagist | All versions | 3.2.7 |

Products: Froala Froala Editor.

## How do I fix CVE-2021-28114?

Upgrade froala/wysiwyg-editor to 3.2.7 or later.

## Is CVE-2021-28114 being exploited?

There is no known exploitation of CVE-2021-28114 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-43263](https://insights.sbomify.com/CVE-2023-43263/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-42426](https://insights.sbomify.com/CVE-2023-42426/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2020-22864](https://insights.sbomify.com/CVE-2020-22864/): Cross site scripting in froala-editor (medium 6.1)
- [CVE-2021-30109](https://insights.sbomify.com/CVE-2021-30109/): Cross-site Scripting in Froala Editor (medium 6.1)
- [CVE-2020-26523](https://insights.sbomify.com/CVE-2020-26523/): Froala WYSIWYG Editor XSS Vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28114 and fix it if it is affected.

What it is: CVE-2021-28114 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Jul 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-28114 in the wild and no public exploit code.

Affected packages and fixed versions:
- froala/wysiwyg-editor (Packagist): affected all versions; fixed in 3.2.7
- froala/wysiwyg-editor (Packagist): affected all versions; fixed in 3.2.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28114/ (Markdown: https://insights.sbomify.com/CVE-2021-28114/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28114
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28114
- OSV: https://osv.dev/vulnerability/CVE-2021-28114

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28114/
Summaries are generated and may contain mistakes; the official description above is the record.
