# CVE-2021-28125: Apache Superset Open Redirect

> Attackers can create malicious short URLs in Apache Superset to redirect users to external sites, potentially facilitating phishing attacks.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-superset-2021-28125, GHSA-pfwg-rxf4-97c3, PYSEC-2021-128, PYSEC-2026-3078

## What is CVE-2021-28125?

CVE-2021-28125 is a medium-severity vulnerability in Apache Superset, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Apache Superset up to and including 1.0.1 allowed for the creation of an external URL that could be malicious. By not checking user input for open redirects the URL shortener functionality would allow for a malicious user to create a short URL for a dashboard that could convince the user to click the link.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2021-28125?

7 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 1.1.0 |
| `apache-superset` | PyPI | All versions | 1.1.0 |
| `apache-superset` | PyPI | All versions | 1.1.0 |
| `superset` | Bitnami | All versions | 1.0.2 |
| `superset` | PyPI | All versions to 0.34.0 | None |
| `superset` | PyPI | All versions to 0.34.0 | None |
| `superset` | PyPI | All versions to 0.34.0 | None |

Products: Apache Superset.

## How do I fix CVE-2021-28125?

Upgrade apache-superset to 1.1.0 or later.

## Is CVE-2021-28125 being exploited?

There is no known exploitation of CVE-2021-28125 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28125 and fix it if it is affected.

What it is: CVE-2021-28125 is a medium-severity vulnerability in Apache Superset, published on 27 Apr 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-28125 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 1.1.0
- apache-superset (PyPI): affected all versions; fixed in 1.1.0
- apache-superset (PyPI): affected all versions; fixed in 1.1.0
- superset (Bitnami): affected all versions; fixed in 1.0.2
- superset (PyPI): affected all versions up to 0.34.0; no fix listed
- superset (PyPI): affected all versions up to 0.34.0; no fix listed
- superset (PyPI): affected all versions up to 0.34.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28125/ (Markdown: https://insights.sbomify.com/CVE-2021-28125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28125
- OSV: https://osv.dev/vulnerability/CVE-2021-28125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28125/
Summaries are generated and may contain mistakes; the official description above is the record.
