# CVE-2021-28164: Authorization Before Parsing and Canonicalization in jetty

> Attackers can access protected WEB-INF files via encoded path traversal, exposing sensitive application configuration data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-28164, GHSA-v7ff-8wcx-gmc5, UBUNTU-CVE-2021-28164

## What is CVE-2021-28164?

CVE-2021-28164 is a medium-severity path traversal vulnerability in Eclipse Jetty, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Eclipse Jetty 9.4.37.v20210219 to 9.4.38.v20210224, the default compliance mode allows requests with URIs that contain %2e or %2e%2e segments to access protected resources within the WEB-INF directory. For example a request to /context/%2e/WEB-INF/web.xml can retrieve the web.xml file. This can reveal sensitive information regarding the implementation of a web application.

Weakness: CWE-551 (Incorrect Behavior Order: Authorization Before Parsing and Canonicalization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-28164?

2 open source packages ship an affected version, including org.eclipse.jetty:jetty-webapp. It affects 17 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-webapp` | Maven | From 9.4.37 | 9.4.39 |
| `org.eclipse.jetty:jetty-webapp` | Maven | From 9.4.37 | 9.4.39 |

Products: Eclipse Jetty, Netapp Cloud Manager, Netapp E-Series Performance Analyzer, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services, Netapp Element Plug-in for Vcenter Server, Netapp Santricity Cloud Connector, Netapp Snapcenter, Netapp Snapcenter Plug-In, Netapp Storage Replication Adapter for Clustered Data Ontap, Netapp Vasa Provider for Clustered Data Ontap, Netapp Virtual Storage Console, Oracle Autovue for Agile Product Lifecycle Management, Oracle Banking Apis, Oracle Banking Digital Experience, Oracle Communications Session Route Manager, Oracle Siebel Core - Automation.

## How do I fix CVE-2021-28164?

Upgrade org.eclipse.jetty:jetty-webapp to 9.4.39 or later.

## Is CVE-2021-28164 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-28164 exists.

Public exploit code:

- Jetty WEB-INF File Disclosure (metasploit)
- Jetty 9.4.37.v20210219 - Information Disclosure (exploitdb)
- jetty /CVE-2021-28164/분석 및 결과 (github_poc): https://github.com/jammy0903/-jettyCVE-2021-28164-
- Vulhub jetty/CVE-2021-28164: Jetty Ambiguous Path Information Disclosure (CVE-2021-28164), run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-jetty-cve-2021-28164
- Eclipse Jetty - Information Disclosure (nuclei): http/cves/2021/CVE-2021-28164.yaml

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28164 and fix it if it is affected.

What it is: CVE-2021-28164 is a medium-severity path traversal vulnerability in Eclipse Jetty, published on 1 Apr 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-28164 exists.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-webapp (Maven): affected from 9.4.37; fixed in 9.4.39
- org.eclipse.jetty:jetty-webapp (Maven): affected from 9.4.37; fixed in 9.4.39

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28164/ (Markdown: https://insights.sbomify.com/CVE-2021-28164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28164
- OSV: https://osv.dev/vulnerability/CVE-2021-28164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28164/
Summaries are generated and may contain mistakes; the official description above is the record.
