# CVE-2021-28169: Jetty Utility Servlets ConcatServlet Double Decoding Information Disclosure Vulnerability

> Attackers can access protected WEB-INF resources like web.xml via doubly encoded paths in ConcatServlet, revealing sensitive application implementation details.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-28169, DLA-2688-1, GHSA-gwcr-j4wh-j3cq, OESA-2021-1249, UBUNTU-CVE-2021-28169

## What is CVE-2021-28169?

CVE-2021-28169 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

For Eclipse Jetty versions <= 9.4.40, <= 10.0.2, <= 11.0.2, it is possible for requests to the ConcatServlet with a doubly encoded path to access protected resources within the WEB-INF directory. For example a request to `/concat?/%2557EB-INF/web.xml` can retrieve the web.xml file. This can reveal sensitive information regarding the implementation of a web application.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-28169?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-servlets. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-servlets` | Maven | All versions | 9.4.41 |
| `org.eclipse.jetty:jetty-servlets` | Maven | All versions | 9.4.41 |
| `org.eclipse.jetty:jetty-servlets` | Maven | From 10.0.0 | 10.0.3 |
| `org.eclipse.jetty:jetty-servlets` | Maven | From 10.0.0 | 10.0.3 |
| `org.eclipse.jetty:jetty-servlets` | Maven | From 11.0.0 | 11.0.3 |
| `org.eclipse.jetty:jetty-servlets` | Maven | From 11.0.0 | 11.0.3 |

Products: Debian Debian Linux, Eclipse Jetty, Netapp Active Iq Unified Manager, Netapp Hci, Netapp Management Services for Element Software, Netapp Snap Creator Framework, Oracle Communications Cloud Native Core Policy, Oracle Rest Data Services.

## How do I fix CVE-2021-28169?

Upgrade org.eclipse.jetty:jetty-servlets to a fixed version for your release line: 9.4.41, 10.0.3 or 11.0.3.

## Is CVE-2021-28169 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-28169 exists.

Public exploit code:

- Eclipse Jetty ConcatServlet - Information Disclosure (nuclei): http/cves/2021/CVE-2021-28169.yaml

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28169 and fix it if it is affected.

What it is: CVE-2021-28169 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 9 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-28169 exists.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-servlets (Maven): affected all versions; fixed in 9.4.41
- org.eclipse.jetty:jetty-servlets (Maven): affected all versions; fixed in 9.4.41
- org.eclipse.jetty:jetty-servlets (Maven): affected from 10.0.0; fixed in 10.0.3
- org.eclipse.jetty:jetty-servlets (Maven): affected from 10.0.0; fixed in 10.0.3
- org.eclipse.jetty:jetty-servlets (Maven): affected from 11.0.0; fixed in 11.0.3
- org.eclipse.jetty:jetty-servlets (Maven): affected from 11.0.0; fixed in 11.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28169/ (Markdown: https://insights.sbomify.com/CVE-2021-28169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28169
- OSV: https://osv.dev/vulnerability/CVE-2021-28169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28169/
Summaries are generated and may contain mistakes; the official description above is the record.
