# CVE-2021-28254: Deserialization in n/a

> Attackers can execute arbitrary commands via a deserialization flaw in the destruct function of the Laravel framework.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Apr 2023
- **Updated:** 5 Mar 2025
- **Also known as:** BIT-laravel-2021-28254, GHSA-5hq5-9pj6-4c2r

## What is CVE-2021-28254?

CVE-2021-28254 is a critical unsafe deserialization vulnerability in n/a, published on 18 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A deserialization vulnerability in the destruct() function of Laravel v8.5.9 allows attackers to execute arbitrary commands.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-28254?

1 open source package ship an affected version, including laravel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel` | Bitnami | From 8.5.9 | 8.5.10 |

Products: Laravel Laravel.

## How do I fix CVE-2021-28254?

Upgrade laravel to 8.5.10 or later.

## Is CVE-2021-28254 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-28254 exists.

## Other vulnerabilities in n/a

- [CVE-2018-15133](https://insights.sbomify.com/CVE-2018-15133/): Laravel Deserialization of Untrusted Data (high 8.1, exploited in the wild)
- [CVE-2020-24940](https://insights.sbomify.com/CVE-2020-24940/): Guard bypass in Eloquent models affecting Laravel illuminate database component (high 7.5)
- [CVE-2020-24941](https://insights.sbomify.com/CVE-2020-24941/): Improper Input Validation in Laravel (high 7.5)
- [CVE-2017-16894](https://insights.sbomify.com/CVE-2017-16894/): Information disclosure in n/a (high 7.5)
- [CVE-2021-21263](https://insights.sbomify.com/CVE-2021-21263/): Query Binding Exploitation in Laravel (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28254 and fix it if it is affected.

What it is: CVE-2021-28254 is a critical unsafe deserialization vulnerability in n/a, published on 18 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-28254 exists.

Affected packages and fixed versions:
- laravel (Bitnami): affected from 8.5.9; fixed in 8.5.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28254/ (Markdown: https://insights.sbomify.com/CVE-2021-28254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28254
- OSV: https://osv.dev/vulnerability/CVE-2021-28254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28254/
Summaries are generated and may contain mistakes; the official description above is the record.
