# CVE-2021-28305: Fix a use-after-free bug in diesels Sqlite backend

> A use-after-free vulnerability in the diesel Rust library's SQLite backend allows attackers to potentially execute arbitrary code or cause a denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-28305, GHSA-j8q9-5rp9-4mv9, RUSTSEC-2021-0037

## What is CVE-2021-28305?

CVE-2021-28305 is a critical use after free vulnerability in n/a, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in the diesel crate before 1.4.6 for Rust. There is a use-after-free in the SQLite backend because the semantics of sqlite3_column_name are not followed.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-28305?

3 open source packages ship an affected version, including diesel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `diesel` | crates.io | All versions | 1.4.6 |
| `diesel` | crates.io | All versions | 1.4.6 |
| `diesel` | crates.io | From 0.0.0-0 | 1.4.6 |

Products: Diesel Diesel.

## How do I fix CVE-2021-28305?

Upgrade diesel to 1.4.6 or later.

## Is CVE-2021-28305 being exploited?

There is no known exploitation of CVE-2021-28305 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28305 and fix it if it is affected.

What it is: CVE-2021-28305 is a critical use after free vulnerability in n/a, published on 12 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28305 in the wild and no public exploit code.

Affected packages and fixed versions:
- diesel (crates.io): affected all versions; fixed in 1.4.6
- diesel (crates.io): affected all versions; fixed in 1.4.6
- diesel (crates.io): affected from 0.0.0-0; fixed in 1.4.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28305/ (Markdown: https://insights.sbomify.com/CVE-2021-28305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28305
- OSV: https://osv.dev/vulnerability/CVE-2021-28305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28305/
Summaries are generated and may contain mistakes; the official description above is the record.
