CVE-2021-28359 Apache Airflow Reflected XSS via Origin Query Argument in URL
Reflected XSS in Apache Airflow allows attackers to execute arbitrary scripts via the origin parameter, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-28359?
CVE-2021-28359 is a medium-severity cross-site scripting vulnerability in Apache Airflow, published on 2 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
The "origin" parameter passed to some of the endpoints like '/trigger' was vulnerable to XSS exploit. This issue affects Apache Airflow versions <1.10.15 in 1.x series and affects 2.0.0 and 2.0.1 and 2.x series. This is the same as CVE-2020-13944 & CVE-2020-17515 but the implemented fix did not fix the issue completely. Update to Airflow 1.10.15 or 2.0.2. Please also update your Python version to the latest available PATCH releases of the installed MINOR versions, example update to Python 3.6.13 if you are on Python 3.6. (Those contain the fix for CVE-2021-23336 https://nvd.nist.gov/vuln/detail/CVE-2021-23336).
Weakness: CWE-79
Which versions are affected by CVE-2021-28359?
6 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow PyPI | All versions | 1.10.15 |
apache-airflow PyPI | All versions | 1.10.15 |
apache-airflow PyPI | From 1.8.1 | 1.10.15, 2.0.2 |
apache-airflow PyPI | From 2.0.0a1 | 2.0.2 |
apache-airflow PyPI | From 2.0.0a1 | 2.0.2 |
airflow Bitnami | From 1.0.0 | 1.10.15, 2.0.2 |
Products include Apache Airflow.
How do I fix CVE-2021-28359?
Upgrade apache-airflow to a fixed version for your release line: 1.10.15 or 2.0.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-28359 being exploited?
There is no known exploitation of CVE-2021-28359 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow
- CVE-2020-13927 Apache Airflow's Experimental API Authentication Bypass
- CVE-2020-11978 Apache Airflow Command Injection
- CVE-2026-33264 Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()
- CVE-2023-25754 Apache Airflow: Privilege escalation using airflow logs
- CVE-2023-22884 Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
Sources
Also known as BIT-airflow-2021-28359, GHSA-3xxv-p78r-4fc6, PYSEC-2021-4.