CVE-2021-28380 Aimeos Typo3 extension contains Cross-site Scripting vulnerability
An attacker with a backend account can inject malicious scripts into the Aimeos e-commerce extension for TYPO3, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-28380?
CVE-2021-28380 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
The aimeos (aka Aimeos shop and e-commerce framework) extension before 19.10.12 and 20.x before 20.10.5 for TYPO3 allows XSS via a backend user account.
Weakness: CWE-79
Which versions are affected by CVE-2021-28380?
4 open source packages ship an affected version, including aimeos/aimeos-typo3. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
aimeos/aimeos-typo3 Packagist | All versions | 19.10.12 |
aimeos/aimeos-typo3 Packagist | All versions | 19.10.12 |
aimeos/aimeos-typo3 Packagist | From 20.0.0 | 20.10.5 |
aimeos/aimeos-typo3 Packagist | From 20.0.0 | 20.10.5 |
Products include Aimeos Project Aimeos.
How do I fix CVE-2021-28380?
Upgrade aimeos/aimeos-typo3 to a fixed version for your release line: 19.10.12 or 20.10.5.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-28380 being exploited?
There is no known exploitation of CVE-2021-28380 in the wild and no public exploit code.
Sources
Also known as GHSA-73wv-rgj7-vjj9.