CVE-2021-28556 Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution
An unauthenticated attacker can execute arbitrary JavaScript via DOM-based XSS in Magento Commerce, requiring user interaction.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-28556?
CVE-2021-28556 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 28 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.
Weakness: CWE-79
Which versions are affected by CVE-2021-28556?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.7 |
magento/community-edition Packagist | All versions | 2.3.7 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2-p1 |
magento Bitnami | All versions | 2.3.7, 2.4.3 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
1 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-28556?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7 or 2.4.2-p1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-28556 being exploited?
There is no known exploitation of CVE-2021-28556 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-28556, GHSA-39ch-rg26-gmq5.