{"answers":{"affected":"7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-28556 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.3.7 or 2.4.2-p1.","what":"CVE-2021-28556 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 28 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-28556 and fix it if it is affected.\n\nWhat it is: CVE-2021-28556 is a medium-severity cross-site scripting vulnerability in Magento Magento, published on 28 Jun 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-28556 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2-p1\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.2-p1\n- magento (Bitnami): affected all versions; fixed in 2.3.7, 2.4.3\n- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed\n- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-28556/ (Markdown: https://insights.sbomify.com/CVE-2021-28556/index.md)","id":"CVE-2021-28556","markdown":"https://insights.sbomify.com/CVE-2021-28556/index.md","name":"CVE-2021-28556","record":{"aliases":["BIT-magento-2021-28556","GHSA-39ch-rg26-gmq5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Magento Commerce","requires_auth":"high_privilege","summary":"An unauthenticated attacker can execute arbitrary JavaScript via DOM-based XSS in Magento Commerce, requiring user interaction.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"magento","vendor":"magento"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a DOM-based Cross-Site Scripting vulnerability on mage-messages cookies. Successful exploitation could lead to arbitrary JavaScript execution by an unauthenticated attacker. User interaction is required for successful exploitation.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Magento Commerce DOM-based cross-site scripting (XSS) could lead to arbitrary javascript execution","id":"CVE-2021-28556","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"magento:magento","products":["magento:magento"],"type":"xss","year":"2021"},"n_packages":7,"n_references":1,"next":{"headline":"Adobe Acrobat Reader out-of-bounds read in PDFLibTool could lead to information exposure","id":"CVE-2021-28557"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.7","2.4.3"],"introduced":["0","2.4.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2021-28556"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-39ch-rg26-gmq5"},{"ecosystem":"Packagist","fixed":["2.3.7"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-39ch-rg26-gmq5"},{"ecosystem":"Packagist","fixed":["2.4.2-p1"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-39ch-rg26-gmq5"},{"ecosystem":"Packagist","fixed":["2.4.2-p1"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-39ch-rg26-gmq5"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.0.2"],"package":"magento/project-community-edition","purl":null,"source":"GHSA-39ch-rg26-gmq5"},{"ecosystem":"Packagist","fixed":[],"introduced":["0"],"last_affected":["2.0.2"],"package":"magento/project-community-edition","purl":"pkg:composer/magento/project-community-edition","source":"GHSA-39ch-rg26-gmq5"}],"prev":{"headline":"Adobe Acrobat Reader out-of-bounds Read could lead to information disclosure","id":"CVE-2021-28555"},"products":["Magento Commerce"],"published":"2021-06-28","related":[{"cvss_score":9.8,"headline":"Magento php object injection vulnerability","id":"CVE-2020-9664","kev_date_added":null,"published":"2020-07-22"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9576","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9578","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9579","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento Security mitigation bypass vulnerability","id":"CVE-2020-9580","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9582","kev_date_added":null,"published":"2020-06-26"},{"cvss_score":9.8,"headline":"Magento command injection vulnerability","id":"CVE-2020-9583","kev_date_added":null,"published":"2020-06-26"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Adobe"]},"summary":"An unauthenticated attacker can execute arbitrary JavaScript via DOM-based XSS in Magento Commerce, requiring user interaction.","url":"https://insights.sbomify.com/CVE-2021-28556/"}