CVE-2021-28563 Magento Commerce improper Authorization via the 'Create Customer' endpoint
An unauthenticated attacker can modify customer data via the Create Customer endpoint, requiring admin console access for exploitation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-28563?
CVE-2021-28563 is a medium-severity missing authorization vulnerability in Magento Magento, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by an Improper Authorization vulnerability via the 'Create Customer' endpoint. Successful exploitation could lead to unauthorized modification of customer data by an unauthenticated attacker. Access to the admin console is required for successful exploitation.
Weakness: CWE-285
Which versions are affected by CVE-2021-28563?
5 open source packages ship an affected version, including magento/community-edition and magento. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.7 |
magento/community-edition Packagist | All versions | 2.3.7 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2-p1 |
magento Bitnami | All versions | 2.3.7, 2.4.3 |
Products include Magento Magento.
How do I fix CVE-2021-28563?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7 or 2.4.2-p1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-28563 being exploited?
There is no known exploitation of CVE-2021-28563 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-28563, GHSA-q9xx-4689-gvv5.