CVE-2021-28583 Magento Commerce insecure storage of sensitive documentation
Attackers can access restricted resources due to insecure storage of sensitive documentation in RMA PDF filenames.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-28583?
CVE-2021-28583 is a high-severity vulnerability in Magento Magento, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are affected by a Violation of Secure Design Principles vulnerability in RMA PDF filename formats. Successful exploitation could allow an attacker to get unauthorized access to restricted resources.
Weakness: CWE-657
Which versions are affected by CVE-2021-28583?
7 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | 2.3.7 |
magento/community-edition Packagist | All versions | 2.3.7 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2-p1 |
magento/community-edition Packagist | From 2.4.0 | 2.4.2-p1 |
magento Bitnami | All versions | 2.3.6, 2.4.2, 2.4.3 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
1 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-28583?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7 or 2.4.2-p1.
Is CVE-2021-28583 being exploited?
There is no known exploitation of CVE-2021-28583 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-28583, GHSA-7gh6-f4jh-3crq.