# CVE-2021-28657: Infinite loop in Apache Tika's MP3 parser

> An attacker can cause a denial of service via an infinite loop in the MP3 parser by providing a crafted or corrupt file.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2021
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2021-28657, GHSA-567x-m4wm-87v8, UBUNTU-CVE-2021-28657

## What is CVE-2021-28657?

CVE-2021-28657 is a medium-severity denial of service vulnerability in Oracle Primavera Unifier, published on 31 Mar 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A carefully crafted or corrupt file may trigger an infinite loop in Tika's MP3Parser up to and including Tika 1.25. Apache Tika users should upgrade to 1.26 or later.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2021-28657?

2 open source packages ship an affected version, including org.apache.tika:tika. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika` | Maven | All versions | 1.26 |
| `org.apache.tika:tika` | Maven | All versions | 1.26 |

Products: Apache Tika, Oracle Communications Messaging Server, Oracle Healthcare Foundation, Oracle Primavera Unifier, Oracle Webcenter Portal.

## How do I fix CVE-2021-28657?

Upgrade org.apache.tika:tika to 1.26 or later.

## Is CVE-2021-28657 being exploited?

There is no known exploitation of CVE-2021-28657 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Primavera Unifier

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2025-54988](https://insights.sbomify.com/CVE-2025-54988/): Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA (high 8.4)
- [CVE-2018-1335](https://insights.sbomify.com/CVE-2018-1335/): Command injection in org.apache.tika:tika-core (high 8.1)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28657 and fix it if it is affected.

What it is: CVE-2021-28657 is a medium-severity denial of service vulnerability in Oracle Primavera Unifier, published on 31 Mar 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-28657 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tika:tika (Maven): affected all versions; fixed in 1.26
- org.apache.tika:tika (Maven): affected all versions; fixed in 1.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28657/ (Markdown: https://insights.sbomify.com/CVE-2021-28657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28657
- OSV: https://osv.dev/vulnerability/CVE-2021-28657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28657/
Summaries are generated and may contain mistakes; the official description above is the record.
