# CVE-2021-28661: SilverStripe GraphQL Server permission checker not inherited by query subclass.

> Attackers can bypass permission checks in SilverStripe GraphQL Server due to a failure to inherit the default permission checker in query subclasses.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-silverstripe-2021-28661, GHSA-r7rh-g777-g5gx

## What is CVE-2021-28661?

CVE-2021-28661 is a medium-severity missing authorization vulnerability in Silverstripe Silverstripe, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Default SilverStripe GraphQL Server (aka silverstripe/graphql) 3.x through 3.4.1 permission checker not inherited by query subclass.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-28661?

3 open source packages ship an affected version, including silverstripe/graphql and silverstripe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/graphql` | Packagist | From 3.0.0 | 3.5.2 |
| `silverstripe/graphql` | Packagist | From 3.0.0 | 3.5.2 |
| `silverstripe` | Bitnami | From 3.0.0 | 3.4.1 |

Products: Silverstripe Silverstripe.

## How do I fix CVE-2021-28661?

Upgrade silverstripe/graphql to 3.5.2 or later.

## Is CVE-2021-28661 being exploited?

There is no known exploitation of CVE-2021-28661 in the wild and no public exploit code.

## Other vulnerabilities in Silverstripe Silverstripe

- [CVE-2007-2321](https://insights.sbomify.com/CVE-2007-2321/): Other in n/a (critical 10.0)
- [CVE-2019-12204](https://insights.sbomify.com/CVE-2019-12204/): Missing warning can lead to unauthenticated admin access in SilverStripe (critical 9.8)
- [CVE-2019-5715](https://insights.sbomify.com/CVE-2019-5715/): Silverstripe Framework SQLi Vulnerability (critical 9.8)
- [CVE-2019-12437](https://insights.sbomify.com/CVE-2019-12437/): Silverstripe CSRF Protection Bypass via GraphQL (high 8.8)
- [CVE-2020-6164](https://insights.sbomify.com/CVE-2020-6164/): Silverstripe CMS information disclosure (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28661 and fix it if it is affected.

What it is: CVE-2021-28661 is a medium-severity missing authorization vulnerability in Silverstripe Silverstripe, published on 7 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28661 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/graphql (Packagist): affected from 3.0.0; fixed in 3.5.2
- silverstripe/graphql (Packagist): affected from 3.0.0; fixed in 3.5.2
- silverstripe (Bitnami): affected from 3.0.0; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28661/ (Markdown: https://insights.sbomify.com/CVE-2021-28661/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28661
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28661
- OSV: https://osv.dev/vulnerability/CVE-2021-28661

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28661/
Summaries are generated and may contain mistakes; the official description above is the record.
