# CVE-2021-28677: Uncontrolled Resource Consumption in Pillow

> A malicious EPS file can cause a denial of service in Pillow due to inefficient line reading logic during the image opening phase.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-28677, BIT-pillow-2021-28677, DEBIAN-CVE-2021-28677, GHSA-q5hq-fp76-qmrc, PYSEC-2021-93, ROOT-APP-PYPI-CVE-2021-28677, UBUNTU-CVE-2021-28677

## What is CVE-2021-28677?

CVE-2021-28677 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Pillow before 8.2.0. For EPS data, the readline implementation used in EPSImageFile has to deal with any combination of \r and \n as line endings. It used an accidentally quadratic method of accumulating lines while looking for a line ending. A malicious EPS file could use this to perform a DoS of Pillow in the open phase, before an image was accepted for opening.

## Which versions are affected by CVE-2021-28677?

4 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | Bitnami | All versions | 8.2.0 |
| `pillow` | PyPI | All versions | 8.2.0 |
| `pillow` | PyPI | All versions | 8.2.0 |
| `pillow` | PyPI | All versions | 8.2.0 |

Products: Fedoraproject Fedora, Python Pillow.

## How do I fix CVE-2021-28677?

Upgrade pillow to 8.2.0 or later.

## Is CVE-2021-28677 being exploited?

There is no known exploitation of CVE-2021-28677 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28677 and fix it if it is affected.

What it is: CVE-2021-28677 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 2 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28677 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (Bitnami): affected all versions; fixed in 8.2.0
- pillow (PyPI): affected all versions; fixed in 8.2.0
- pillow (PyPI): affected all versions; fixed in 8.2.0
- pillow (PyPI): affected all versions; fixed in 8.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28677/ (Markdown: https://insights.sbomify.com/CVE-2021-28677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28677
- OSV: https://osv.dev/vulnerability/CVE-2021-28677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28677/
Summaries are generated and may contain mistakes; the official description above is the record.
