{"answers":{"affected":"2 open source packages ship an affected version, including devise_masquerade. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-28680 in the wild and no public exploit code.","fix":"Upgrade devise_masquerade to 1.3.1 or later.","what":"CVE-2021-28680 is a high-severity authentication bypass vulnerability in n/a, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-28680 and fix it if it is affected.\n\nWhat it is: CVE-2021-28680 is a high-severity authentication bypass vulnerability in n/a, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-28680 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- devise_masquerade (RubyGems): affected all versions; fixed in 1.3.1\n- devise_masquerade (RubyGems): affected all versions; fixed in 1.3.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-28680/ (Markdown: https://insights.sbomify.com/CVE-2021-28680/index.md)","id":"CVE-2021-28680","markdown":"https://insights.sbomify.com/CVE-2021-28680/index.md","name":"CVE-2021-28680","record":{"aliases":["GHSA-25f5-gc4h-hc22"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Ruby authentication gem","requires_auth":"none","summary":"Attackers can impersonate users without knowing their password salt if the server secret is leaked, bypassing standard Devise protections.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"devise_masquerade","vendor":"devise_masquerade_project"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"The devise_masquerade gem before 1.3 allows certain attacks when a password's salt is unknown. An application that uses this gem to let administrators masquerade/impersonate users loses one layer of security protection compared to a situation where Devise (without this extension) is used. If the server-side secret_key_base value became publicly known (for instance if it is committed to a public repository by mistake), there are still other protections in place that prevent an attacker from impersonating any user on the site. When masquerading is not used in a plain Devise application, one must know the password salt of the target user if one wants to encrypt and sign a valid session cookie. When devise_masquerade is used, however, an attacker can decide which user the \"back\" action will go back to without knowing that user's password salt and simply knowing the user ID, by manipulating the session cookie and pretending that a user is already masqueraded by an administrator.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Privilege Management in devise_masquerade","id":"CVE-2021-28680","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"In github.com/pion/webrtc, failed DTLS certificate verification doesn't stop data channel communication","id":"CVE-2021-28681"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"devise_masquerade","purl":null,"source":"GHSA-25f5-gc4h-hc22"},{"ecosystem":"RubyGems","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"devise_masquerade","purl":"pkg:gem/devise_masquerade","source":"GHSA-25f5-gc4h-hc22"}],"prev":{"headline":"Insufficient Verification of Data Authenticity in Pillow","id":"CVE-2021-28678"},"products":["n/a"],"published":"2021-12-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can impersonate users without knowing their password salt if the server secret is leaked, bypassing standard Devise protections.","url":"https://insights.sbomify.com/CVE-2021-28680/"}