# CVE-2021-28680: Improper Privilege Management in devise_masquerade

> Attackers can impersonate users without knowing their password salt if the server secret is leaked, bypassing standard Devise protections.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-25f5-gc4h-hc22

## What is CVE-2021-28680?

CVE-2021-28680 is a high-severity authentication bypass vulnerability in n/a, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The devise_masquerade gem before 1.3 allows certain attacks when a password's salt is unknown. An application that uses this gem to let administrators masquerade/impersonate users loses one layer of security protection compared to a situation where Devise (without this extension) is used. If the server-side secret_key_base value became publicly known (for instance if it is committed to a public repository by mistake), there are still other protections in place that prevent an attacker from impersonating any user on the site. When masquerading is not used in a plain Devise application, one must know the password salt of the target user if one wants to encrypt and sign a valid session cookie. When devise_masquerade is used, however, an attacker can decide which user the "back" action will go back to without knowing that user's password salt and simply knowing the user ID, by manipulating the session cookie and pretending that a user is already masqueraded by an administrator.

## Which versions are affected by CVE-2021-28680?

2 open source packages ship an affected version, including devise_masquerade. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `devise_masquerade` | RubyGems | All versions | 1.3.1 |
| `devise_masquerade` | RubyGems | All versions | 1.3.1 |

Products: Devise Masquerade Project Devise Masquerade.

## How do I fix CVE-2021-28680?

Upgrade devise_masquerade to 1.3.1 or later.

## Is CVE-2021-28680 being exploited?

There is no known exploitation of CVE-2021-28680 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-28680 and fix it if it is affected.

What it is: CVE-2021-28680 is a high-severity authentication bypass vulnerability in n/a, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-28680 in the wild and no public exploit code.

Affected packages and fixed versions:
- devise_masquerade (RubyGems): affected all versions; fixed in 1.3.1
- devise_masquerade (RubyGems): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-28680/ (Markdown: https://insights.sbomify.com/CVE-2021-28680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-28680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-28680
- OSV: https://osv.dev/vulnerability/CVE-2021-28680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-28680/
Summaries are generated and may contain mistakes; the official description above is the record.
