CVE-2021-28682 Integer overflow in n/a
A remote attacker can cause unexpected timeout calculations and potential denial of service by sending a very large grpc-timeout value to the Envoy proxy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-28682?
CVE-2021-28682 is a high-severity vulnerability in Envoyproxy Envoy, published on 20 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Envoy through 1.71.1. There is a remotely exploitable integer overflow in which a very large grpc-timeout value leads to unexpected timeout calculations.
Weakness: CWE-190
Which versions are affected by CVE-2021-28682?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | From 1.14.6 | 1.14.7, 1.15.4, 1.16.3, 1.17.2 |
Products include Envoyproxy Envoy.
How do I fix CVE-2021-28682?
Upgrade envoy to a fixed version for your release line: 1.14.7, 1.15.4, 1.16.3 or 1.17.2.
Is CVE-2021-28682 being exploited?
There is no known exploitation of CVE-2021-28682 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2021-28682, GHSA-r22g-5f3x-xjgg.