CVE-2021-28683 Null dereference in n/a
Remote attackers can crash the Envoy proxy by sending unknown TLS alert codes, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-28683?
CVE-2021-28683 is a high-severity vulnerability in Envoyproxy Envoy, published on 20 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Envoy through 1.71.1. There is a remotely exploitable NULL pointer dereference and crash in TLS when an unknown TLS alert code is received.
Weakness: CWE-476
Which versions are affected by CVE-2021-28683?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | From 1.16.2 | 1.16.3, 1.17.2 |
Products include Envoyproxy Envoy.
How do I fix CVE-2021-28683?
Upgrade envoy to a fixed version for your release line: 1.16.3 or 1.17.2.
Is CVE-2021-28683 being exploited?
There is no known exploitation of CVE-2021-28683 in the wild and no public exploit code.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2021-28683.